Running Script in Office365

Jan 10, 2013 at 2:11 AM
Edited Jan 10, 2013 at 1:24 PM

Hi! I am attempting to create multi "bulk" sites under Sharepoint with this script. I have been successful upto the point of where I get the message “Create SharePoint 2010 Sites from CSV Script - Get-SPScripts.com” succesfully.

But when I invoke the script to start creating the sites I get error messages back. 

I couldn't see any help to overcome the erors thrown out for Start-SPAssignment or Stop-SPAssignment. Would greatly appreciate any possible guidance. 

Thank you!

Jan 10, 2013 at 2:29 AM
Edited Jan 10, 2013 at 1:23 PM

But when I invoke the script to start creating the sites I get error messages back. Specifically:

PS C:\Install> New-SPSitesFromCsv -StartSite https://crosspointsolutions.sharepoint.com/Sandbox/Bulk_Sites -CsvFile "C:\

Install\SitesDemo.csv" -SiteTemplate "Team Site"

Start-SPAssignment : The term 'Start-SPAssignment' is not recognized as the name of a cmdlet, function, script file,

or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and

try again.

At C:\Install\Get-SPScripts.New-SPSitesFromCsv.ps1:11 char:5

+     Start-SPAssignment –Global

+     ~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : ObjectNotFound: (Start-SPAssignment:String) [], CommandNotFoundException

    + FullyQualifiedErrorId : CommandNotFoundException

 

The script has stopped because there has been an error.

Stop-SPAssignment : The term 'Stop-SPAssignment' is not recognized as the name of a cmdlet, function, script file, or

operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try

again.

At C:\Install\Get-SPScripts.New-SPSitesFromCsv.ps1:138 char:9

+         Stop-SPAssignment -Global

+         ~~~~~~~~~~~~~~~~~

    + CategoryInfo          : ObjectNotFound: (Stop-SPAssignment:String) [], CommandNotFoundException

    + FullyQualifiedErrorId : CommandNotFoundException

 

PS C:\Install>

Jan 10, 2013 at 1:07 PM
Edited Jan 10, 2013 at 1:08 PM

I commented out the Start-SPAssignment and Stop-SPAssignment because I understand the cmdlet is not recognized in Sharepoint Online, but I still get an error.

PS C:\Install> New-SPSitesFromCsv -StartSite https://crosspointsolutions.sharepoint.com/Sandbox/Bulk_Sites -CsvFile "C:\Install\SitesDemo.csv" -SiteTemplate "Team Site"

The script has stopped because there has been an error.

PS C:\Install>